Xref в Max 2017. Отображение и рендеринг

Автор
Сообщение
Zava
Возраст:
Пол: М
На сайте c: 26.08.2010
Сообщения: 253
Откуда:

Друзья, сталкнулся с проблемой после перехода с 2014 на 2017 макс. 

Огромная сцена, множество объектов. Вставляются в сцену с помощью Xref Scene и биндятся к прокси объектам.  

Галочка Visible всегда снимается, что бы не грузить вьюпорты. На рендерах все должно работать отлично. Однако в 2017 случается неприятное - если галочка Visible снята - Xref объекты не только не отображаются во вьюпорте (как и должно), но и не рендерятся. В слоях видно, что с объектов снят атрибут Visible (для слоев включен, но все объекты отключены). Включить его нельзя. Соответственно если галочку visible поставить - все рендерится как и положено, но тогда теряется весь смысл Xref. Строго говоря такое поведение однозначно противоречит документации, где прописано, что галка отключает отображение исключительно для вьюпорта и не влияет на рендер.

Сталкивался кто ни будь с подобным и лечится ли сея проблема? 

P.S. Рендерер Corona 1.5.2 В 2014 Max'е проблем нет. Смена рендерера показывает, что проблема скорее в максе (что видно по поведению слоев)

TRAFFIC_rus
Возраст:
Пол: М
На сайте c: 24.05.2010
Сообщения: 538
Откуда: Москва

Ага. Есть такой глюк.

Макс 2011, Vray 2.55. При локальном рендере Xref сцены в режиме invisible рендерятся нормально. Но при дистрибутивном - сетевые компы не рендерят скрытое. Приходится включать видимость.

Zava
Возраст:
Пол: М
На сайте c: 26.08.2010
Сообщения: 253
Откуда:

Цитата TRAFFIC_rus:

Ага. Есть такой глюк.

Макс 2011, Vray 2.55. При локальном рендере Xref сцены в режиме invisible рендерятся нормально. Но при дистрибутивном - сетевые компы не рендерят скрытое. Приходится включать видимость.

В моем случае проблема с локальным рендером.

Проблема топика кажется решилось после установки SP3. Но появилась новая. Теперь старые файлы или не открываются или открываются очень долго (часа не хватило, не дождался). 2014 макс открывает нормально. Что характерно если сделать мердж - то все мерджится нормально без ошибок и моментально. Прилепил все Xref, проблемы с отображением нет. Но после сохранения и открытия все висит. Похоже придется не просто пересобирать сцены но еще и перелопатить все сцены, что вставляются Xref'ом... жесть какая-то. 

Проблема усугубляется тем что 2014 макс открывает все старые сцены, кроме блин основной в которую все собирается, почему-то именно в ней после установки 2017 макса и плагинов что-то покрашилось >_<

Убиться веником...

Gustavlegion
Возраст: 27
Пол: М
На сайте c: 14.10.2014
Сообщения: 4
Откуда:
Цитата Zava:

Цитата TRAFFIC_rus:

Ага. Есть такой глюк.

Макс 2011, Vray 2.55. При локальном рендере Xref сцены в режиме invisible рендерятся нормально. Но при дистрибутивном - сетевые компы не рендерят скрытое. Приходится включать видимость.

В моем случае проблема с локальным рендером.

Проблема топика кажется решилось после установки SP3. Но появилась новая. Теперь старые файлы или не открываются или открываются очень долго (часа не хватило, не дождался). 2014 макс открывает нормально. Что характерно если сделать мердж - то все мерджится нормально без ошибок и моментально. Прилепил все Xref, проблемы с отображением нет. Но после сохранения и открытия все висит. Похоже придется не просто пересобирать сцены но еще и перелопатить все сцены, что вставляются Xref'ом... жесть какая-то. 

Проблема усугубляется тем что 2014 макс открывает все старые сцены, кроме блин основной в которую все собирается, почему-то именно в ней после установки 2017 макса и плагинов что-то покрашилось >_<

Убиться веником...

https://forums.autodesk.com/t5/3ds-max-forum/xref-scene-not-visible/m-p/6683667#M125763  

Читают эту тему: